[FRPythoneers] xml difference in 1.5 to 2.1

Ken Kinder kkinder at tridog.com
Wed Aug 22 11:18:36 MDT 2001


I don't think you should need to use the core object. Here is what my
XML processing looks like with DOM and it works on both.

import xml.dom.minidom
dom = xml.dom.minidom

rootelement = dom.Element('tag')
...

If you're serious about XML, check out 4suite.org -- they have much
better (IMHO) XML modules, although if you're shipping an application,
it's a pain to get users to get that stuff installed.

"Andrew R. Diederich" wrote:
> 
> I'm trying out a simple example from Sean McGraths XML Processing with
> Python book, but I think I've been bitten by a version difference, maybe
> in the pyxml version?
> 
> What I'm trying is
> >>> from xml.dom import core
> Traceback (most recent call last):
>   File "<pyshell#1>", line 1, in ?
>     from xml.dom import core
> ImportError: cannot import name core
> 
> but on a SuSE box that still has 1.5.2 on it, that works just fine.  (The
> first box is a win2k box with the activestate 2.1 on it.)
> 
> any ideas?  I tried installing the latest pyxml, but still no joy.
> 
> --
> Andrew Diederich
> 
> _______________________________________________
> This message sent by the FRPythoneers mailing list.
> Unsubscribe: echo unsubscribe | FRPythoneers-request at lists.community.tummy.com
> URL: http://lists.community.tummy.com/mailman/listinfo/frpythoneers



More information about the FRPythoneers mailing list